diff options
author | Fomalhaut Weisszwerg | 2023-11-27 12:24:57 +0000 |
---|---|---|
committer | GitHub | 2023-11-27 12:24:57 +0000 |
commit | b7f98d1d9930b15f07342f67d2560aecd4ebc401 (patch) | |
tree | 76735bafef2675f2441776a295c1aac813c48f50 /Cargo.toml | |
parent | 3f9788daaa0669a81e218d18636f9abb285b6c15 (diff) |
set Cargo feature resolver to v2 (#8917)
* fix: version of Cargo feature resolver.
This commit solve the ambiguity to determin the version of resolver.
To get more detail, see the following two documents:
- https://doc.rust-lang.org/cargo/reference/resolver.html#resolver-versions
- https://doc.rust-lang.org/edition-guide/rust-2021/default-cargo-resolver.html
* unified: Rust edition in all workspaces.
Now, the Rust 2021 is available in all workspaces.
* fined up: Cargo.toml by using workspace inheritance.
To get more detail of the `workspace.package` table, see a following document:
- https://doc.rust-lang.org/cargo/reference/workspaces.html#the-package-table
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -1,4 +1,5 @@ [workspace] +resolver = "2" members = [ "helix-core", "helix-view", @@ -37,3 +38,8 @@ package.helix-term.opt-level = 2 [workspace.dependencies] tree-sitter = { version = "0.20", git = "https://github.com/tree-sitter/tree-sitter", rev = "ab09ae20d640711174b8da8a654f6b3dec93da1a" } nucleo = "0.2.0" + +[workspace.package] +edition = "2021" +license = "MPL-2.0" +rust-version = "1.70" |