aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorYusuf Bera Ertan2023-02-25 04:06:30 +0000
committerYusuf Bera Ertan2023-02-25 04:06:30 +0000
commit309735aa2d9516a734165ee066f2c9a080f9849a (patch)
tree57e38d320085d4d5fd7746094c260179ec41134f /flake.nix
parente5af0f1d49547295be796a600c0841135f331618 (diff)
build(nix): fix devshell
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 66fb641d..2ac76488 100644
--- a/flake.nix
+++ b/flake.nix
@@ -120,9 +120,11 @@
else pkgs.clangStdenv;
rustFlagsEnv =
if stdenv.isLinux
- then "$RUSTFLAGS\" -C link-arg=-fuse-ld=lld -C target-cpu=native -Clink-arg=-Wl,--no-rosegment\""
+ then ''$RUSTFLAGS -C link-arg=-fuse-ld=lld -C target-cpu=native -Clink-arg=-Wl,--no-rosegment''
else "$RUSTFLAGS";
in {
+ # by default NCI adds rust-analyzer component, but helix toolchain doesn't have rust-analyzer
+ nci.toolchains.shell.components = ["rust-src" "rustfmt" "clippy"];
nci.projects."helix-project".relPath = "";
nci.crates."helix-term" = {
overrides = {