aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorMichael Davis2022-09-13 13:50:53 +0000
committerGitHub2022-09-13 13:50:53 +0000
commitec81ec1e8d26e3a99ed713b79381a77daf817d34 (patch)
tree805e308d20498bf9cf8d06750210dd31028501cb /flake.nix
parentd38950bdf9ac786dc518fa723b92a3f189f2b960 (diff)
flake: Fix devShell on aarch64-darwin (#3810)
LLDB is marked broken on all arches except for x86_64-linux. With this change, I can use `nix develop` on aarch64-darwin.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index abcb2cb2..8cb4b663 100644
--- a/flake.nix
+++ b/flake.nix
@@ -92,8 +92,9 @@
prev.packages
++ (
with common.pkgs;
- [lld_13 lldb cargo-flamegraph rust-analyzer]
+ [lld_13 cargo-flamegraph rust-analyzer]
++ (lib.optional (stdenv.isx86_64 && stdenv.isLinux) cargo-tarpaulin)
+ ++ (lib.optional stdenv.isLinux lldb)
);
env =
prev.env