aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorYt2023-05-19 13:21:05 +0000
committerGitHub2023-05-19 13:21:05 +0000
commitff442eecd054e67081158ef2f0eeab0ed9156ca5 (patch)
treebb1c20e80ddce9da07b707c87ce682b286076ec6 /flake.nix
parent53f47bc47771c94dab51626ca025be28e62eba0c (diff)
nix: add overlay for convenient package usage (#7078)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 6dcaf6cc..81f0a05c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -64,7 +64,7 @@
};
in
inp.parts.lib.mkFlake {inputs = inp;} {
- imports = [inp.nci.flakeModule];
+ imports = [inp.nci.flakeModule inp.parts.flakeModules.easyOverlay];
systems = [
"x86_64-linux"
"x86_64-darwin"
@@ -146,6 +146,10 @@
packages.helix-dev = makeOverridableHelix config.packages.helix-unwrapped-dev {};
packages.default = config.packages.helix;
+ overlayAttrs = {
+ inherit (config.packages) helix;
+ };
+
devShells.default = config.nci.outputs."helix-project".devShell.overrideAttrs (old: {
nativeBuildInputs =
(old.nativeBuildInputs or [])