aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorBlaž Hrastnik2022-02-15 01:11:59 +0000
committerBlaž Hrastnik2022-02-15 01:12:37 +0000
commit8a7aec641408477ff62dd56f4f74337de6a7ab80 (patch)
treec061d82165504cbe6dd8c585ccdd3c4129792e56 /flake.nix
parent225484c26c4e19c5c803709c4565458205089a9b (diff)
fix: nix flake build
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 0d22c5c1..660207ed 100644
--- a/flake.nix
+++ b/flake.nix
@@ -21,7 +21,8 @@
defaultOutputs = { app = "hx"; package = "helix"; };
overrides = {
crateOverrides = common: _: rec {
- # link languages and theme toml files since helix-view expects them
+ # link languages and theme toml files since helix-core/helix-view expects them
+ helix-core = _: { preConfigure = "ln -s ${common.root}/{languages.toml,theme.toml,base16_theme.toml} .."; };
helix-view = _: { preConfigure = "ln -s ${common.root}/{languages.toml,theme.toml,base16_theme.toml} .."; };
helix-syntax = prev: {
src =