aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJared Ramirez2022-01-13 00:40:07 +0000
committerGitHub2022-01-13 00:40:07 +0000
commita2fad4fcb0c4a0547a86cb18820f2c8612991a1d (patch)
tree292027cee876e4170be332e6d66a651dbde903e2 /flake.nix
parentf77dbc7c8350ccc3f5270cae4a7d53e47f36a06c (diff)
Fix Nix flake (#1455)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix77
1 files changed, 45 insertions, 32 deletions
diff --git a/flake.nix b/flake.nix
index cbf10c97..e1b9d0b4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -20,44 +20,57 @@
# Set default package to helix-term release build
defaultOutputs = { app = "hx"; package = "helix"; };
overrides = {
- crateOverrides = common: _: {
- helix-term = prev: {
- # link languages and theme toml files since helix-term expects them (for tests)
- preConfigure = "ln -s ${common.root}/{languages.toml,theme.toml} ..";
- buildInputs = (prev.buildInputs or [ ]) ++ [ common.cCompiler.cc.lib ];
- };
+ crateOverrides = common: _: rec {
# link languages and theme toml files since helix-view expects them
- helix-view = _: { preConfigure = "ln -s ${common.root}/{languages.toml,theme.toml} .."; };
- helix-syntax = _prev: {
+ helix-view = _: { preConfigure = "ln -s ${common.root}/{languages.toml,theme.toml,base16_theme.toml} .."; };
+ helix-syntax = prev: {
+ src =
+ let
+ pkgs = common.pkgs;
+ helix = pkgs.fetchgit {
+ url = "https://github.com/helix-editor/helix.git";
+ rev = "a8fd33ac012a79069ef1409503a2edcf3a585153";
+ fetchSubmodules = true;
+ sha256 = "sha256-5AtOC55ttWT+7RYMboaFxpGZML51ix93wAkYJTt+8JI=";
+ };
+ in
+ pkgs.runCommand prev.src.name { } ''
+ mkdir -p $out
+ ln -s ${prev.src}/* $out
+ ln -sf ${helix}/helix-syntax/languages $out
+ '';
preConfigure = "mkdir -p ../runtime/grammars";
postInstall = "cp -r ../runtime $out/runtime";
};
- };
- mainBuild = common: prev:
- let
- inherit (common) pkgs lib;
- helixSyntax = lib.buildCrate {
- root = self;
- memberName = "helix-syntax";
- defaultCrateOverrides = {
- helix-syntax = common.crateOverrides.helix-syntax;
+ helix-term = prev:
+ let
+ inherit (common) pkgs lib;
+ helixSyntax = lib.buildCrate {
+ root = self;
+ memberName = "helix-syntax";
+ defaultCrateOverrides = {
+ helix-syntax = helix-syntax;
+ };
+ release = false;
};
- release = false;
+ runtimeDir = pkgs.runCommand "helix-runtime" { } ''
+ mkdir -p $out
+ ln -s ${common.root}/runtime/* $out
+ ln -sf ${helixSyntax}/runtime/grammars $out
+ '';
+ in
+ {
+ # link languages and theme toml files since helix-term expects them (for tests)
+ preConfigure = "ln -s ${common.root}/{languages.toml,theme.toml,base16_theme.toml} ..";
+ buildInputs = (prev.buildInputs or [ ]) ++ [ common.cCompiler.cc.lib ];
+ nativeBuildInputs = [ pkgs.makeWrapper ];
+ postFixup = ''
+ if [ -f "$out/bin/hx" ]; then
+ wrapProgram "$out/bin/hx" --set HELIX_RUNTIME "${runtimeDir}"
+ fi
+ '';
};
- runtimeDir = pkgs.runCommand "helix-runtime" { } ''
- mkdir -p $out
- ln -s ${common.root}/runtime/* $out
- ln -sf ${helixSyntax}/runtime/grammars $out
- '';
- in
- lib.optionalAttrs (common.memberName == "helix-term") {
- nativeBuildInputs = [ pkgs.makeWrapper ];
- postFixup = ''
- if [ -f "$out/bin/hx" ]; then
- wrapProgram "$out/bin/hx" --set HELIX_RUNTIME "${runtimeDir}"
- fi
- '';
- };
+ };
shell = common: prev: {
packages = prev.packages ++ (with common.pkgs; [ lld_13 lldb cargo-tarpaulin ]);
env = prev.env ++ [