aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-05-03 13:39:53 +0000
committerBlaž Hrastnik2021-05-03 13:39:53 +0000
commitb6a22e955b6146345674951859f6ef97e29355bc (patch)
tree15f6e8dd74c181a1fc4e719aa7a48fc6e8b5afd6 /flake.nix
parent3038c2ef6d392a570aaed9c7d51427363c43046d (diff)
Closer to a full flake build via naersk.
Blocked on https://github.com/NixOS/nix/issues/4423, build doesn't see submodules.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 23763dac..8ad3c90a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -12,8 +12,15 @@
flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; overlays = [ rust-overlay.overlay ]; };
- naerskLib = pkgs.callPackage naersk {
- inherit (pkgs.rust-bin.stable.latest.default) rustc cargo;
+ rust = (pkgs.rustChannelOf {
+ date = "2021-05-01";
+ channel = "nightly";
+ }).minimal; # cargo, rustc and rust-std
+ naerskLib = naersk.lib."${system}".override {
+ # naersk can't build with stable?!
+ # inherit (pkgs.rust-bin.stable.latest) rustc cargo;
+ rustc = rust;
+ cargo = rust;
};
in rec {
packages.helix = naerskLib.buildPackage {