aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJohann Dahm2022-05-03 22:32:44 +0000
committerGitHub2022-05-03 22:32:44 +0000
commite529ca1b92ac03fe1e4386756ee5811212ce96bd (patch)
tree91bd1f9f9408e3187b1a596152ca4527b3347f37 /flake.nix
parentd2b1add1f41c9d9a655a4637e3e276eb92e8eefb (diff)
Fix build on aarch64-darwin (#1789)
Co-authored-by: Yusuf Bera Ertan <y.bera003.06@protonmail.com>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 38ba9fd0..495e441a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -25,6 +25,7 @@
package = "helix";
};
overrides = {
+ cCompiler = common: if common.pkgs.stdenv.isLinux then common.pkgs.gcc else common.pkgs.clang;
crateOverrides = common: _: {
helix-term = prev:
let
@@ -57,7 +58,7 @@
env = prev.env ++ [
{ name = "HELIX_RUNTIME"; eval = "$PWD/runtime"; }
{ name = "RUST_BACKTRACE"; value = "1"; }
- { name = "RUSTFLAGS"; value = "-C link-arg=-fuse-ld=lld -C target-cpu=native -Clink-arg=-Wl,--no-rosegment"; }
+ { name = "RUSTFLAGS"; value = if common.pkgs.stdenv.isLinux then "-C link-arg=-fuse-ld=lld -C target-cpu=native -Clink-arg=-Wl,--no-rosegment" else ""; }
];
};
};