aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-11-22 01:32:35 +0000
committerBlaž Hrastnik2021-12-03 01:02:07 +0000
commita45df126999e4c081c0f2b26e20f2a7fedcd7b87 (patch)
tree767d4b74fe0bab5149b53a3901518859eedecd43 /flake.nix
parent119dee2980708f75150e39c19f92de029d92dad0 (diff)
nix: Update to lld 13, drop flake-compat (was unused)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 296a68d5..cbf10c97 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,10 +9,6 @@
inputs.nixpkgs.follows = "nixpkgs";
inputs.rustOverlay.follows = "rust-overlay";
};
- flakeCompat = {
- url = "github:edolstra/flake-compat";
- flake = false;
- };
};
outputs = inputs@{ self, nixCargoIntegration, ... }:
@@ -63,7 +59,7 @@
'';
};
shell = common: prev: {
- packages = prev.packages ++ (with common.pkgs; [ lld_12 lldb cargo-tarpaulin ]);
+ packages = prev.packages ++ (with common.pkgs; [ lld_13 lldb cargo-tarpaulin ]);
env = prev.env ++ [
{ name = "HELIX_RUNTIME"; eval = "$PWD/runtime"; }
{ name = "RUST_BACKTRACE"; value = "1"; }