aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorTimothy DeHerrera2021-06-08 23:00:04 +0000
committerBlaž Hrastnik2021-06-10 13:00:53 +0000
commit1a774d61bb3ec28ac202a43450f35017f918e46e (patch)
tree6b59f421e15aaa1cdc031708b3e9ee99ba80c890 /flake.nix
parent1b14e9a19aeba2750bb57d9f97cc12ca3624a21d (diff)
Fix flake package
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 8ad3c90a..3626be9a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,6 +6,12 @@
flake-utils.url = "github:numtide/flake-utils";
rust-overlay.url = "github:oxalica/rust-overlay";
naersk.url = "github:nmattia/naersk";
+ helix = {
+ flake = false;
+ url = "https://github.com/helix-editor/helix";
+ type = "git";
+ submodules = true;
+ };
};
outputs = inputs@{ self, nixpkgs, naersk, rust-overlay, flake-utils, ... }:
@@ -25,7 +31,7 @@
in rec {
packages.helix = naerskLib.buildPackage {
pname = "helix";
- root = ./.;
+ root = inputs.helix;
};
defaultPackage = packages.helix;
devShell = pkgs.callPackage ./shell.nix {};