aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorYusuf Bera Ertan2022-11-01 00:52:03 +0000
committerGitHub2022-11-01 00:52:03 +0000
commit3881fef39d01c94a09b8f5da67decc2c3ccb3660 (patch)
treed236da0087eeb30fde3b243817c8d082049be913 /flake.nix
parente5319ea8c52d6c97ce901426c2714a26f535be0b (diff)
build(nix): update nci, fixup flake (#4537)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix225
1 files changed, 112 insertions, 113 deletions
diff --git a/flake.nix b/flake.nix
index 8cb4b663..b1d3f01e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -21,57 +21,124 @@
...
}: let
lib = nixpkgs.lib;
+ ncl = nci.lib.nci-lib;
mkRootPath = rel:
builtins.path {
path = "${toString ./.}/${rel}";
name = rel;
};
+ filteredSource = let
+ pathsToIgnore = [
+ ".envrc"
+ ".ignore"
+ ".github"
+ "runtime"
+ "screenshot.png"
+ "book"
+ "contrib"
+ "docs"
+ "README.md"
+ "CHANGELOG.md"
+ "shell.nix"
+ "default.nix"
+ "grammars.nix"
+ "flake.nix"
+ "flake.lock"
+ ];
+ ignorePaths = path: type: let
+ # split the nix store path into its components
+ components = lib.splitString "/" path;
+ # drop off the `/nix/hash-source` section from the path
+ relPathComponents = lib.drop 4 components;
+ # reassemble the path components
+ relPath = lib.concatStringsSep "/" relPathComponents;
+ in
+ lib.all (p: ! (lib.hasPrefix p relPath)) pathsToIgnore;
+ in
+ builtins.path {
+ name = "helix-source";
+ path = toString ./.;
+ # filter out unnecessary paths
+ filter = ignorePaths;
+ };
outputs = nci.lib.makeOutputs {
root = ./.;
- renameOutputs = {"helix-term" = "helix";};
- # Set default app to hx (binary is from helix-term release build)
- # Set default package to helix-term release build
- defaultOutputs = {
- app = "hx";
- package = "helix";
+ config = common: {
+ outputs = {
+ # rename helix-term to helix since it's our main package
+ rename = {"helix-term" = "helix";};
+ # Set default app to hx (binary is from helix-term release build)
+ # Set default package to helix-term release build
+ defaults = {
+ app = "hx";
+ package = "helix";
+ };
+ };
+ cCompiler.package = with common.pkgs;
+ if stdenv.isLinux
+ then gcc
+ else clang;
+ shell = {
+ packages = with common.pkgs;
+ [lld_13 cargo-flamegraph rust-analyzer]
+ ++ (lib.optional (stdenv.isx86_64 && stdenv.isLinux) cargo-tarpaulin)
+ ++ (lib.optional stdenv.isLinux lldb);
+ env = [
+ {
+ name = "HELIX_RUNTIME";
+ eval = "$PWD/runtime";
+ }
+ {
+ name = "RUST_BACKTRACE";
+ value = "1";
+ }
+ {
+ name = "RUSTFLAGS";
+ value =
+ if common.pkgs.stdenv.isLinux
+ then "-C link-arg=-fuse-ld=lld -C target-cpu=native -Clink-arg=-Wl,--no-rosegment"
+ else "";
+ }
+ ];
+ };
};
- overrides = {
- cCompiler = common:
- with common.pkgs;
- if stdenv.isLinux
- then gcc
- else clang;
- crateOverrides = common: _: {
- helix-term = prev: {
- src = builtins.path {
- name = "helix-source";
- path = toString ./.;
- # filter out unneeded stuff that cause rebuilds
- filter = path: type:
- lib.all
- (n: builtins.baseNameOf path != n)
- [
- ".envrc"
- ".ignore"
- ".github"
- "runtime"
- "screenshot.png"
- "book"
- "contrib"
- "docs"
- "README.md"
- "shell.nix"
- "default.nix"
- "grammars.nix"
- "flake.nix"
- "flake.lock"
- ];
- };
+ pkgConfig = common: {
+ helix-term = {
+ # Wrap helix with runtime
+ wrapper = _: old: let
+ inherit (common) pkgs;
+ makeOverridableHelix = old: config: let
+ grammars = pkgs.callPackage ./grammars.nix config;
+ runtimeDir = pkgs.runCommand "helix-runtime" {} ''
+ mkdir -p $out
+ ln -s ${mkRootPath "runtime"}/* $out
+ rm -r $out/grammars
+ ln -s ${grammars} $out/grammars
+ '';
+ helix-wrapped =
+ common.internal.pkgsSet.utils.wrapDerivation old
+ {
+ nativeBuildInputs = [pkgs.makeWrapper];
+ makeWrapperArgs = config.makeWrapperArgs or [];
+ }
+ ''
+ rm -rf $out/bin
+ mkdir -p $out/bin
+ ln -sf ${old}/bin/* $out/bin/
+ wrapProgram "$out/bin/hx" ''${makeWrapperArgs[@]} --set HELIX_RUNTIME "${runtimeDir}"
+ '';
+ in
+ helix-wrapped
+ // {override = makeOverridableHelix old;};
+ in
+ makeOverridableHelix old {};
+ overrides.fix-build.overrideAttrs = prev: {
+ src = filteredSource;
# disable fetching and building of tree-sitter grammars in the helix-term build.rs
HELIX_DISABLE_AUTO_GRAMMAR_BUILD = "1";
- buildInputs = (prev.buildInputs or []) ++ [common.cCompiler.cc.lib];
+ buildInputs = ncl.addBuildInputs prev [common.config.cCompiler.package.cc.lib];
# link languages and theme toml files since helix-term expects them (for tests)
preConfigure = ''
@@ -87,88 +154,20 @@
meta.mainProgram = "hx";
};
};
- shell = common: prev: {
- packages =
- prev.packages
- ++ (
- with common.pkgs;
- [lld_13 cargo-flamegraph rust-analyzer]
- ++ (lib.optional (stdenv.isx86_64 && stdenv.isLinux) cargo-tarpaulin)
- ++ (lib.optional stdenv.isLinux lldb)
- );
- env =
- prev.env
- ++ [
- {
- name = "HELIX_RUNTIME";
- eval = "$PWD/runtime";
- }
- {
- name = "RUST_BACKTRACE";
- value = "1";
- }
- {
- name = "RUSTFLAGS";
- value =
- if common.pkgs.stdenv.isLinux
- then "-C link-arg=-fuse-ld=lld -C target-cpu=native -Clink-arg=-Wl,--no-rosegment"
- else "";
- }
- ];
- };
};
};
- makeOverridableHelix = system: old: config: let
- pkgs = nixpkgs.legacyPackages.${system};
- grammars = pkgs.callPackage ./grammars.nix config;
- runtimeDir = pkgs.runCommand "helix-runtime" {} ''
- mkdir -p $out
- ln -s ${mkRootPath "runtime"}/* $out
- rm -r $out/grammars
- ln -s ${grammars} $out/grammars
- '';
- helix-wrapped =
- pkgs.runCommand "${old.name}-wrapped"
- {
- inherit (old) pname version meta;
-
- nativeBuildInputs = [pkgs.makeWrapper];
- makeWrapperArgs = config.makeWrapperArgs or [];
- }
- ''
- mkdir -p $out
- cp -r --no-preserve=mode,ownership ${old}/* $out/
- chmod +x $out/bin/*
- wrapProgram "$out/bin/hx" ''${makeWrapperArgs[@]} --set HELIX_RUNTIME "${runtimeDir}"
- '';
- in
- helix-wrapped
- // {override = makeOverridableHelix system old;};
in
outputs
// {
- apps =
- lib.mapAttrs
- (
- system: apps: rec {
- default = hx;
- hx = {
- type = "app";
- program = lib.getExe self.${system}.packages.helix;
- };
- }
- )
- outputs.apps;
packages =
lib.mapAttrs
(
- system: packages: rec {
- default = helix;
- helix = makeOverridableHelix system helix-unwrapped {};
- helix-debug = makeOverridableHelix system helix-unwrapped-debug {};
- helix-unwrapped = packages.helix;
- helix-unwrapped-debug = packages.helix-debug;
- }
+ system: packages:
+ packages
+ // {
+ helix-unwrapped = packages.helix.passthru.unwrapped;
+ helix-unwrapped-debug = packages.helix-debug.passthru.unwrapped;
+ }
)
outputs.packages;
};