aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-11-22 01:32:35 +0000
committerBlaž Hrastnik2021-11-22 01:32:35 +0000
commit3b3c396ca4da14b2df8ffd3f9ef3abede3c72a4e (patch)
treefe2466692d5c1351a9c2be5442c14b0170975e3c /flake.nix
parent05d3ad4a0e989b2bcc34a1b396a396621be2e612 (diff)
nix: Update to lld 13, drop flake-compat (was unused)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 296a68d5..cbf10c97 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,10 +9,6 @@
inputs.nixpkgs.follows = "nixpkgs";
inputs.rustOverlay.follows = "rust-overlay";
};
- flakeCompat = {
- url = "github:edolstra/flake-compat";
- flake = false;
- };
};
outputs = inputs@{ self, nixCargoIntegration, ... }:
@@ -63,7 +59,7 @@
'';
};
shell = common: prev: {
- packages = prev.packages ++ (with common.pkgs; [ lld_12 lldb cargo-tarpaulin ]);
+ packages = prev.packages ++ (with common.pkgs; [ lld_13 lldb cargo-tarpaulin ]);
env = prev.env ++ [
{ name = "HELIX_RUNTIME"; eval = "$PWD/runtime"; }
{ name = "RUST_BACKTRACE"; value = "1"; }