aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorMichael Davis2022-02-21 12:39:23 +0000
committerBlaž Hrastnik2022-03-10 08:31:57 +0000
commitb157c5a8a4472cff68de3a9be66e220dc4b80a9f (patch)
treec67cd0462e3cb3a6b7627ef000b12b0b001afcfa /flake.nix
parent6fcab90d16f9493c0c4738312061a26e473ab12a (diff)
fetch and compile tree-sitter grammars in helix-term build
This restores much of the behavior that existed before this PR: helix will build the grammars when compiling. The difference is that now fetching is also done during the build phase and is done much more quickly - both shallow and in parallel.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 71825431..c4838ffd 100644
--- a/flake.nix
+++ b/flake.nix
@@ -35,6 +35,8 @@
overrides = {
crateOverrides = common: _: rec {
helix-term = prev: {
+ # disable fetching and building of tree-sitter grammars in the helix-term build.rs
+ HELIX_DISABLE_AUTO_GRAMMAR_BUILD = "1";
buildInputs = (prev.buildInputs or [ ]) ++ [ common.cCompiler.cc.lib ];
nativeBuildInputs = (prev.nativeBuildInputs or [ ]) ++ [ common.pkgs.makeWrapper ];
preConfigure = ''