aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorMichael Davis2022-03-09 14:34:52 +0000
committerBlaž Hrastnik2022-03-10 08:31:57 +0000
commite01c53551db82146b59415498fc8f588f237b22c (patch)
treeccc4f8666e5f359fbbe4614ae97aa13a4e134b9b /flake.nix
parent7044d7d804ad798207594e1b3bb5bd80a96d3da0 (diff)
flake: use builtins.fetchTree to shallow-clone grammar repos
Here we perform a shallow fetch using builtins.fetchTree. In order to make this work, we need to specify the `ref' for any repository that doesn't have `master' as its default branch (I'm not sure why this limitation exists since we don't need this when performing the shallow fetch in `--grammar build') This `ref' field is ignored by helix, so I have left it undocumented for now, but I could be open to documenting it.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 1 insertions, 9 deletions
diff --git a/flake.nix b/flake.nix
index e1cd5036..38ba9fd0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -12,17 +12,9 @@
inputs.nixpkgs.follows = "nixpkgs";
inputs.rustOverlay.follows = "rust-overlay";
};
- # NOTE: the flake looks like it is hanging when it pulls this input because
- # the submodules take a long time to clone. This will be fixed in #1659.
- helix = {
- url = "https://github.com/helix-editor/helix.git";
- type = "git";
- submodules = true;
- flake = false;
- };
};
- outputs = inputs@{ nixCargoIntegration, helix, ... }:
+ outputs = inputs@{ nixCargoIntegration, ... }:
nixCargoIntegration.lib.makeOutputs {
root = ./.;
renameOutputs = { "helix-term" = "helix"; };