aboutsummaryrefslogtreecommitdiff
path: root/grammars.nix
diff options
context:
space:
mode:
authorYusuf Bera Ertan2022-07-27 17:52:07 +0000
committerGitHub2022-07-27 17:52:07 +0000
commit85a5df03911be8f7845921a503ffb707bfc6bab4 (patch)
treed3fae944b5abc6f16ab7968d98bd3328a2f40841 /grammars.nix
parent2f1d3d0899543eec56b5cc05638a8d3cdb5e696a (diff)
build(nix): add a way to override what grammars get built (#3141)
Diffstat (limited to 'grammars.nix')
-rw-r--r--grammars.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/grammars.nix b/grammars.nix
index 2f50662e..066fa69d 100644
--- a/grammars.nix
+++ b/grammars.nix
@@ -4,6 +4,8 @@
runCommandLocal,
runCommandNoCC,
yj,
+ includeGrammarIf ? _: true,
+ ...
}: let
# HACK: nix < 2.6 has a bug in the toml parser, so we convert to JSON
# before parsing
@@ -102,12 +104,13 @@
runHook postFixup
'';
};
+ grammarsToBuild = builtins.filter includeGrammarIf gitGrammars;
builtGrammars =
builtins.map (grammar: {
inherit (grammar) name;
artifact = buildGrammar grammar;
})
- gitGrammars;
+ grammarsToBuild;
grammarLinks =
builtins.map (grammar: "ln -s ${grammar.artifact}/${grammar.name}.so $out/${grammar.name}.so")
builtGrammars;