aboutsummaryrefslogtreecommitdiff
path: root/helix-core/Cargo.toml
diff options
context:
space:
mode:
authornotoria2021-06-06 15:55:05 +0000
committerBlaž Hrastnik2021-06-10 13:00:08 +0000
commit1a3a92463405fdd4738fbdbfda212aef58a2919d (patch)
treebc47fdc4957a6890cbad286c52a445ba5d96da9a /helix-core/Cargo.toml
parentaebdef8257173b31df77ae02bb23ec2abfd07e5c (diff)
Implement Debug for data structure as a feature
Diffstat (limited to 'helix-core/Cargo.toml')
-rw-r--r--helix-core/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/helix-core/Cargo.toml b/helix-core/Cargo.toml
index 2d7a6ae8..08d10726 100644
--- a/helix-core/Cargo.toml
+++ b/helix-core/Cargo.toml
@@ -10,6 +10,7 @@ license = "MPL-2.0"
[features]
embed_runtime = ["rust-embed"]
+debug = []
[dependencies]
helix-syntax = { path = "../helix-syntax" }
@@ -17,7 +18,7 @@ helix-syntax = { path = "../helix-syntax" }
ropey = "1.2"
smallvec = "1.4"
tendril = "0.4.2"
-unicode-segmentation = "1.6"
+unicode-segmentation = { git = "https://github.com/unicode-rs/unicode-segmentation.git" }
unicode-width = "0.1"
unicode-general-category = "0.4.0"
# slab = "0.4.2"