aboutsummaryrefslogtreecommitdiff
path: root/helix-core/Cargo.toml
diff options
context:
space:
mode:
authorSkyler Hawthorne2022-09-17 13:34:56 +0000
committerMichael Davis2023-03-20 23:34:40 +0000
commit58ea1930544df165a4a1342932e4dd8cb93e14ea (patch)
tree3cdc8910f20963027cf444f1d1a4b3392c399b2f /helix-core/Cargo.toml
parenta264faa98d348a13318f9ccbb0d979882a112654 (diff)
Allow explicit newlines in test DSL
The current test DSL currently has no way to express being at the end of a line, save for putting an explicit LF or CRLF inside the `#[|]#`. The problem with this approach is that it can add unintended extra new lines if used in conjunction with raw strings, which insert newlines for you. This is a simple attempt to mitigate this problem. If there is an explicit newline character at the end of the selection, and then it is immediately followed by the same newline character at the right end of the selection, this following newline is removed. This way, one can express a cursor at the end of a line explicitly.
Diffstat (limited to 'helix-core/Cargo.toml')
-rw-r--r--helix-core/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/helix-core/Cargo.toml b/helix-core/Cargo.toml
index 62ec87b4..8618f586 100644
--- a/helix-core/Cargo.toml
+++ b/helix-core/Cargo.toml
@@ -49,3 +49,4 @@ textwrap = "0.16.0"
[dev-dependencies]
quickcheck = { version = "1", default-features = false }
+indoc = "1.0.6"