aboutsummaryrefslogtreecommitdiff
path: root/helix-core/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2022-01-17 07:28:56 +0000
committerBlaž Hrastnik2022-03-17 00:29:47 +0000
commit59f05088b9628086b35631338e49ae8f061dcba2 (patch)
treeb8e87e318e2194a9473aca0ce799a4e32bffa33a /helix-core/Cargo.toml
parentc6bd105484fbaf35812dddc41b8fb32cb054fc54 (diff)
Optimize rendering by using Ropey::byte_slice
This avoids costly conversions via byte_to_char (which are then reversed back into bytes internally in Ropey). Reduces time spent in slice/byte_to_char from ~24% to ~5%.
Diffstat (limited to 'helix-core/Cargo.toml')
-rw-r--r--helix-core/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/helix-core/Cargo.toml b/helix-core/Cargo.toml
index 8152da57..3e5aabaa 100644
--- a/helix-core/Cargo.toml
+++ b/helix-core/Cargo.toml
@@ -15,7 +15,8 @@ include = ["src/**/*", "README.md"]
[dependencies]
helix-loader = { version = "0.6", path = "../helix-loader" }
-ropey = "1.3"
+# ropey = "1.3"
+ropey = { git = "https://github.com/cessen/ropey" }
smallvec = "1.8"
smartstring = "1.0.0"
unicode-segmentation = "1.9"