aboutsummaryrefslogtreecommitdiff
path: root/helix-core/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-05-14 10:21:46 +0000
committerBlaž Hrastnik2021-05-14 10:21:46 +0000
commit4a9d1163e04ba0fc29f8532afd35381b7df55e48 (patch)
tree7b8413c60c267d0a06ddbfa18e1d367b4b6d2309 /helix-core/Cargo.toml
parent726072085d019b1ce9e3cdf4e1557a1148723482 (diff)
Hacky way to specify indent scopes per language via toml configs.
Can't do it via a scm query nicely because it returns an iterator over all the matches, whereas we want to traverse the tree ourselves. Can't extract the pattern data from a parsed query either. Oh well, toml files for now.
Diffstat (limited to 'helix-core/Cargo.toml')
-rw-r--r--helix-core/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/helix-core/Cargo.toml b/helix-core/Cargo.toml
index 7868ec58..33b59cb1 100644
--- a/helix-core/Cargo.toml
+++ b/helix-core/Cargo.toml
@@ -22,5 +22,6 @@ once_cell = "1.4"
regex = "1"
serde = { version = "1.0", features = ["derive"] }
+toml = "0.5"
etcetera = "0.3"