summaryrefslogtreecommitdiff
path: root/helix-core/Cargo.toml
diff options
context:
space:
mode:
authorBrian Dawn2021-06-03 20:46:56 +0000
committerBlaž Hrastnik2021-06-06 01:49:17 +0000
commit62d181de78077200d7b229ce6f91b2b14129d998 (patch)
tree890a622aed18f5e61097dde4efababd2af1af7fe /helix-core/Cargo.toml
parent8c2fa12ffc006de787992b4022263be033ac8200 (diff)
Provide a feature flag to be able to embed the runtime folder.
These changes provide a new feature flag "embed_runtime" that when enabled and built in release mode will embed the runtime folder into the resulting binary.
Diffstat (limited to 'helix-core/Cargo.toml')
-rw-r--r--helix-core/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/helix-core/Cargo.toml b/helix-core/Cargo.toml
index b5f2ef77..35f30ede 100644
--- a/helix-core/Cargo.toml
+++ b/helix-core/Cargo.toml
@@ -7,6 +7,10 @@ license = "MPL-2.0"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[features]
+embed_runtime = []
+
[dependencies]
helix-syntax = { path = "../helix-syntax" }
@@ -24,3 +28,4 @@ serde = { version = "1.0", features = ["derive"] }
toml = "0.5"
etcetera = "0.3"
+rust-embed="5.9.0"