aboutsummaryrefslogtreecommitdiff
path: root/helix-core/Cargo.toml
diff options
context:
space:
mode:
authorVince Mutolo2022-05-02 14:24:22 +0000
committerGitHub2022-05-02 14:24:22 +0000
commitf9baced216df60122f2aae08d382931d77901ca9 (patch)
tree44326181702d03e18f5d9c810331c2993524296c /helix-core/Cargo.toml
parent567ddef388986dd2cea5c7f3eb1aa1a978c3e6d3 (diff)
add reflow command (#2128)
* add reflow command Users need to be able to hard-wrap text for many applications, including comments in code, git commit messages, plaintext documentation, etc. It often falls to the user to manually insert line breaks where appropriate in order to hard-wrap text. This commit introduces the "reflow" command (both in the TUI and core library) to automatically hard-wrap selected text to a given number of characters (defined by Unicode "extended grapheme clusters"). It handles lines with a repeated prefix, such as comments ("//") and indentation. * reflow: consider newlines to be word separators * replace custom reflow impl with textwrap crate * Sync reflow command docs with book * reflow: add default max_line_len language setting Co-authored-by: Vince Mutolo <vince@mutolo.org>
Diffstat (limited to 'helix-core/Cargo.toml')
-rw-r--r--helix-core/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/helix-core/Cargo.toml b/helix-core/Cargo.toml
index 6e019a42..ab937f0b 100644
--- a/helix-core/Cargo.toml
+++ b/helix-core/Cargo.toml
@@ -41,6 +41,7 @@ encoding_rs = "0.8"
chrono = { version = "0.4", default-features = false, features = ["alloc", "std"] }
etcetera = "0.3"
+textwrap = "0.15.0"
[dev-dependencies]
quickcheck = { version = "1", default-features = false }