aboutsummaryrefslogtreecommitdiff
path: root/helix-dap/Cargo.toml
diff options
context:
space:
mode:
authorDmitry Sharshakov2021-08-12 13:35:15 +0000
committerBlaž Hrastnik2021-08-20 04:43:54 +0000
commit0f6e81b85be6e7e8f08446f3cd373da38dd67360 (patch)
tree7f79b7017ed700652f2dee868c88d084c5d0be4d /helix-dap/Cargo.toml
parentd4c17b633c09ab2a0ba8794a6650dcfb67f50ea9 (diff)
Initial debug adapter protocol implementation
Diffstat (limited to 'helix-dap/Cargo.toml')
-rw-r--r--helix-dap/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/helix-dap/Cargo.toml b/helix-dap/Cargo.toml
new file mode 100644
index 00000000..6adaaedd
--- /dev/null
+++ b/helix-dap/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "helix-dap"
+version = "0.3.0"
+authors = ["Blaž Hrastnik <blaz@mxxn.io>"]
+edition = "2018"
+license = "MPL-2.0"
+description = "DAP client implementation for Helix project"
+categories = ["editor"]
+repository = "https://github.com/helix-editor/helix"
+homepage = "https://helix-editor.com"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0"
+log = "0.4"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+thiserror = "1.0"
+tokio = { version = "1.9", features = ["rt", "rt-multi-thread", "io-util", "io-std", "time", "process", "macros", "fs", "parking_lot"] }