aboutsummaryrefslogtreecommitdiff
path: root/helix-loader/Cargo.toml
diff options
context:
space:
mode:
authorMichael Davis2024-01-23 14:29:07 +0000
committerBlaž Hrastnik2024-01-24 06:47:49 +0000
commit6d724a8f331f4b2a8f1a001e990cf6129dc50b00 (patch)
treecc2d8c6068ec8ad58aa29320c08c6218b2e8070d /helix-loader/Cargo.toml
parent6bfe1ddc53f542d62e242fd4aaf6748dda1b0e71 (diff)
Re-export `which` from `helix-stdx::env`
We use `which::which` in many crates, so `which` was a separate dependency across all of them. We can centralize `which` into the stdx crate so it's easy for all crates to depend on it. I also moved the rest of `helix-view/src/env.rs` into helix-stdx's `env` module since it only contained a thin wrapper around `which` and `std::env`.
Diffstat (limited to 'helix-loader/Cargo.toml')
-rw-r--r--helix-loader/Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/helix-loader/Cargo.toml b/helix-loader/Cargo.toml
index 08da7f29..469bedc1 100644
--- a/helix-loader/Cargo.toml
+++ b/helix-loader/Cargo.toml
@@ -24,7 +24,6 @@ etcetera = "0.8"
tree-sitter.workspace = true
once_cell = "1.19"
log = "0.4"
-which = "5.0.0"
# TODO: these two should be on !wasm32 only