aboutsummaryrefslogtreecommitdiff
path: root/helix-loader/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2022-03-27 02:23:58 +0000
committerBlaž Hrastnik2022-05-01 02:39:07 +0000
commit9191af3f8d73d2101c46192a4a80c41a19012320 (patch)
treea5259e9a819868317096ab3ca322fed24c2e7b97 /helix-loader/Cargo.toml
parent8bb89dafa2f3bae8d2c7605b880973992b04480f (diff)
helix-loader + helix-core now compile for WASM
Diffstat (limited to 'helix-loader/Cargo.toml')
-rw-r--r--helix-loader/Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/helix-loader/Cargo.toml b/helix-loader/Cargo.toml
index 607d1a0a..c8cbf6d1 100644
--- a/helix-loader/Cargo.toml
+++ b/helix-loader/Cargo.toml
@@ -15,11 +15,16 @@ serde = { version = "1.0", features = ["derive"] }
toml = "0.5"
etcetera = "0.3"
tree-sitter = "0.20"
-libloading = "0.7"
once_cell = "1.9"
log = "0.4"
+# TODO: these two should be on !wasm32 only
+
# cloning/compiling tree-sitter grammars
cc = { version = "1" }
threadpool = { version = "1.0" }
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+libloading = "0.7"
+