aboutsummaryrefslogtreecommitdiff
path: root/helix-lsp/Cargo.toml
diff options
context:
space:
mode:
authorMatouš Dzivjak2022-12-09 03:57:03 +0000
committerGitHub2022-12-09 03:57:03 +0000
commit8abed3bd78200fc5f7e3890fd853c17ce518d157 (patch)
tree8edd1bf79e309fe32bb3cd6dad9848a4113ffdc8 /helix-lsp/Cargo.toml
parent6798a6651f9d314eacefddfd051661b030ca9d78 (diff)
feat(lsp): pass client_info on initialization (#4904)
Pass client name ('helix') and client version (version / git hash) to LSP server on initialization.
Diffstat (limited to 'helix-lsp/Cargo.toml')
-rw-r--r--helix-lsp/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/helix-lsp/Cargo.toml b/helix-lsp/Cargo.toml
index 41884e73..05c5467e 100644
--- a/helix-lsp/Cargo.toml
+++ b/helix-lsp/Cargo.toml
@@ -13,6 +13,7 @@ homepage = "https://helix-editor.com"
[dependencies]
helix-core = { version = "0.6", path = "../helix-core" }
+helix-loader = { version = "0.6", path = "../helix-loader" }
anyhow = "1.0"
futures-executor = "0.3"