aboutsummaryrefslogtreecommitdiff
path: root/helix-lsp/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2020-12-17 10:30:41 +0000
committerBlaž Hrastnik2020-12-17 10:35:29 +0000
commit4f9cde25cf6ed9204e4b3b82dbc07ef42f1435cf (patch)
treefa7a1f7dc6edef0060d2089990e1ca202da459c2 /helix-lsp/Cargo.toml
parent7c75ec04e8db825f24f311d0c26109310738183d (diff)
Bump deps.
Diffstat (limited to 'helix-lsp/Cargo.toml')
-rw-r--r--helix-lsp/Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/helix-lsp/Cargo.toml b/helix-lsp/Cargo.toml
index 2ecd0cc1..d22d8636 100644
--- a/helix-lsp/Cargo.toml
+++ b/helix-lsp/Cargo.toml
@@ -9,9 +9,10 @@ edition = "2018"
[dependencies]
helix-core = { path = "../helix-core" }
helix-view = { path = "../helix-view" }
+
once_cell = "1.4"
-lsp-types = { version = "0.84", features = ["proposed"] }
+lsp-types = { version = "0.85", features = ["proposed"] }
smol = "1.2"
url = "2"
pathdiff = "0.2"
@@ -20,7 +21,7 @@ glob = "0.3"
anyhow = "1"
serde_json = "1.0"
serde = { version = "1.0", features = ["derive"] }
-jsonrpc-core = "15.1"
+jsonrpc-core = "16.0"
futures-util = "0.3"
-thiserror = "1"
-log = "0.4"
+thiserror = "1.0"
+log = "~0.4"