summaryrefslogtreecommitdiff
path: root/helix-lsp/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2020-10-18 09:01:06 +0000
committerBlaž Hrastnik2020-12-03 04:04:42 +0000
commitf03830b047f0db9d9bb4576f771b5988329be46f (patch)
treee796fed4764bd4466e27293aed5a8ed6cb03a4e8 /helix-lsp/Cargo.toml
parent8adcf5083ffc12532ecca7594a2192acd954dd3a (diff)
wip: Basic LSP lifecycle requests/notifications.
Diffstat (limited to 'helix-lsp/Cargo.toml')
-rw-r--r--helix-lsp/Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/helix-lsp/Cargo.toml b/helix-lsp/Cargo.toml
index 6fd59bf4..1942fc24 100644
--- a/helix-lsp/Cargo.toml
+++ b/helix-lsp/Cargo.toml
@@ -9,7 +9,12 @@ edition = "2018"
[dependencies]
lsp-types = { version = "0.82", features = ["proposed"] }
smol = "1.2"
-url = "2.1.1"
+url = "2"
pathdiff = "0.2.0"
shellexpand = "2.0.0"
-glob = "0.3.0"
+glob = "0.3"
+anyhow = "1"
+serde_json = "1.0"
+serde = { version = "1.0", features = ["derive"] }
+jsonrpc-core = "15.1"
+futures-util = "0.3"