aboutsummaryrefslogtreecommitdiff
path: root/helix-syntax/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2020-09-09 05:41:12 +0000
committerBlaž Hrastnik2020-09-09 05:41:12 +0000
commit7eac12a4bb02aaa96f63de612077a12df1d5fedc (patch)
treec54b40453427e9f029577d710ebb92325a4d4349 /helix-syntax/Cargo.toml
parent563e094916b6e0d3ef0fafe8141372116e35ebde (diff)
Add helix-syntax as a wrapper around tree-sitter parsers.
Diffstat (limited to 'helix-syntax/Cargo.toml')
-rw-r--r--helix-syntax/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/helix-syntax/Cargo.toml b/helix-syntax/Cargo.toml
new file mode 100644
index 00000000..ef8ed863
--- /dev/null
+++ b/helix-syntax/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "helix-syntax"
+version = "0.1.0"
+authors = ["Blaž Hrastnik <blaz@mxxn.io>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+tree-sitter = "0.16"
+enum-iterator = "0.6"
+
+[build-dependencies]
+cc = { version = "1", features = ["parallel"] }