aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorBrian Dawn2021-06-03 20:46:56 +0000
committerBlaž Hrastnik2021-06-06 01:49:17 +0000
commit62d181de78077200d7b229ce6f91b2b14129d998 (patch)
tree890a622aed18f5e61097dde4efababd2af1af7fe /helix-term/Cargo.toml
parent8c2fa12ffc006de787992b4022263be033ac8200 (diff)
Provide a feature flag to be able to embed the runtime folder.
These changes provide a new feature flag "embed_runtime" that when enabled and built in release mode will embed the runtime folder into the resulting binary.
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index 59d5b325..3751b5ab 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -8,6 +8,9 @@ license = "MPL-2.0"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[features]
+embed_runtime = ["helix-core/embed_runtime"]
+
[[bin]]
name = "hx"
path = "src/main.rs"