aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-10-27 01:04:23 +0000
committerBlaž Hrastnik2021-10-27 03:25:00 +0000
commit2cee0c58baf601995e6fd7ef774d8556bb1af6b9 (patch)
treefe1d4c4228feb70eebbbc0187c67d85e7ca075aa /helix-term/Cargo.toml
parent3fe353c47cb9c56d8e08396be476cf53b688fe36 (diff)
minor: Rearrange helix-term Cargo.toml
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index cf1f44d5..72bb8fec 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -25,16 +25,20 @@ helix-core = { version = "0.4", path = "../helix-core" }
helix-view = { version = "0.4", path = "../helix-view" }
helix-lsp = { version = "0.4", path = "../helix-lsp" }
+# Rendering
+tui = { path = "../helix-tui", package = "helix-tui", default-features = false, features = ["crossterm"] }
+crossterm = { version = "0.22", features = ["event-stream"] }
+signal-hook = "0.3"
+[target.'cfg(not(windows))'.dependencies] # https://github.com/vorner/signal-hook/issues/100
+signal-hook-tokio = { version = "0.3", features = ["futures-v0_3"] }
+
anyhow = "1"
once_cell = "1.8"
tokio = { version = "1", features = ["rt", "rt-multi-thread", "io-util", "io-std", "time", "process", "macros", "fs", "parking_lot"] }
num_cpus = "1"
-tui = { path = "../helix-tui", package = "helix-tui", default-features = false, features = ["crossterm"] }
-crossterm = { version = "0.22", features = ["event-stream"] }
-signal-hook = "0.3"
-
futures-util = { version = "0.3", features = ["std", "async-await"], default-features = false }
+tokio-stream = "0.1.7"
# Logging
fern = "0.6"
@@ -56,7 +60,4 @@ serde = { version = "1.0", features = ["derive"] }
# ripgrep for global search
grep-regex = "0.1.9"
grep-searcher = "0.1.8"
-tokio-stream = "0.1.7"
-[target.'cfg(not(windows))'.dependencies] # https://github.com/vorner/signal-hook/issues/100
-signal-hook-tokio = { version = "0.3", features = ["futures-v0_3"] }