aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-10-27 15:21:30 +0000
committerBlaž Hrastnik2021-10-27 15:21:30 +0000
commit5501669f8c77a1b919d8d243795b280eeab3a11b (patch)
tree0ce6bec612fbb27e22bb2cde1753d1e4adc0106c /helix-term/Cargo.toml
parent4a3285110343e43186302fc08ac8e0fc2aa31ce8 (diff)
Revert "minor: Rearrange helix-term Cargo.toml"
This reverts commit 2cee0c58baf601995e6fd7ef774d8556bb1af6b9.
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml15
1 files changed, 7 insertions, 8 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index 72bb8fec..cf1f44d5 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -25,20 +25,16 @@ helix-core = { version = "0.4", path = "../helix-core" }
helix-view = { version = "0.4", path = "../helix-view" }
helix-lsp = { version = "0.4", path = "../helix-lsp" }
-# Rendering
-tui = { path = "../helix-tui", package = "helix-tui", default-features = false, features = ["crossterm"] }
-crossterm = { version = "0.22", features = ["event-stream"] }
-signal-hook = "0.3"
-[target.'cfg(not(windows))'.dependencies] # https://github.com/vorner/signal-hook/issues/100
-signal-hook-tokio = { version = "0.3", features = ["futures-v0_3"] }
-
anyhow = "1"
once_cell = "1.8"
tokio = { version = "1", features = ["rt", "rt-multi-thread", "io-util", "io-std", "time", "process", "macros", "fs", "parking_lot"] }
num_cpus = "1"
+tui = { path = "../helix-tui", package = "helix-tui", default-features = false, features = ["crossterm"] }
+crossterm = { version = "0.22", features = ["event-stream"] }
+signal-hook = "0.3"
+
futures-util = { version = "0.3", features = ["std", "async-await"], default-features = false }
-tokio-stream = "0.1.7"
# Logging
fern = "0.6"
@@ -60,4 +56,7 @@ serde = { version = "1.0", features = ["derive"] }
# ripgrep for global search
grep-regex = "0.1.9"
grep-searcher = "0.1.8"
+tokio-stream = "0.1.7"
+[target.'cfg(not(windows))'.dependencies] # https://github.com/vorner/signal-hook/issues/100
+signal-hook-tokio = { version = "0.3", features = ["futures-v0_3"] }