aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorCole Helbling2023-11-25 12:55:49 +0000
committerGitHub2023-11-25 12:55:49 +0000
commit8b0ae3d27912799d59e4948ff11d3a5428e32ce4 (patch)
tree579190b16189202c1dbb9ef86c607e9c75616c8d /helix-term/Cargo.toml
parent090ed97e0045bfad1e5bff8b96c61707b996b85a (diff)
bump MSRV to 1.70.0 (#8877)
* rust-toolchain.toml: bump MSRV to 1.70.0 With Firefox 120 released on 21 November 2023, the MSRV is now 1.70.0. * Fix cargo fmt with Rust 1.70.0 * Fix cargo clippy with Rust 1.70.0 * Fix cargo doc with Rust 1.70.0 * rust-toolchain.toml: add clippy component * .github: bump dtolnay/rust-toolchain to 1.70 * helix-term: bump rust-version to 1.70 * helix-view/gutter: use checked_ilog10 to count digits * helix-core/syntax: use MAIN_SEPARATOR_STR constant * helix-view/handlers/dap: use Display impl for displaying process spawn error * WIP: helix-term/commands: use checked math to assert ranges cannot overlap
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index 378f25f8..672e6f84 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -10,7 +10,7 @@ repository = "https://github.com/helix-editor/helix"
homepage = "https://helix-editor.com"
include = ["src/**/*", "README.md"]
default-run = "hx"
-rust-version = "1.65"
+rust-version = "1.70"
[features]
default = ["git"]