aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorMichael Davis2022-02-21 12:39:23 +0000
committerBlaž Hrastnik2022-03-10 08:31:57 +0000
commitb157c5a8a4472cff68de3a9be66e220dc4b80a9f (patch)
treec67cd0462e3cb3a6b7627ef000b12b0b001afcfa /helix-term/Cargo.toml
parent6fcab90d16f9493c0c4738312061a26e473ab12a (diff)
fetch and compile tree-sitter grammars in helix-term build
This restores much of the behavior that existed before this PR: helix will build the grammars when compiling. The difference is that now fetching is also done during the build phase and is done much more quickly - both shallow and in parallel.
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index 86d72561..48365743 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -67,9 +67,8 @@ grep-searcher = "0.1.8"
# Remove once retain_mut lands in stable rust
retain_mut = "0.1.7"
-# compiling grammars
-cc = { version = "1" }
-threadpool = { version = "1.0" }
-
[target.'cfg(not(windows))'.dependencies] # https://github.com/vorner/signal-hook/issues/100
signal-hook-tokio = { version = "0.3", features = ["futures-v0_3"] }
+
+[build-dependencies]
+helix-loader = { version = "0.6", path = "../helix-loader" }