aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorSkyler Hawthorne2023-12-05 01:54:18 +0000
committerGitHub2023-12-05 01:54:18 +0000
commitbf7c4e165946f7a5be48c9d7e8abb8e68f066882 (patch)
tree2e5660f2562e0b6f424af4792348e7c3546e86ab /helix-term/Cargo.toml
parent44c3d48a941c5e2d6484c808c9066b91cfbcf0ec (diff)
use workspace inheritance for common version (#8925)
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml30
1 files changed, 15 insertions, 15 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index eaed8375..33594c0f 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -1,16 +1,16 @@
[package]
name = "helix-term"
-version = "0.6.0"
description = "A post-modern text editor."
-authors = ["Blaž Hrastnik <blaz@mxxn.io>"]
-edition.workspace = true
-license.workspace = true
-categories = ["editor", "command-line-utilities"]
-repository = "https://github.com/helix-editor/helix"
-homepage = "https://helix-editor.com"
include = ["src/**/*", "README.md"]
default-run = "hx"
+version.workspace = true
+authors.workspace = true
+edition.workspace = true
+license.workspace = true
rust-version.workspace = true
+categories.workspace = true
+repository.workspace = true
+homepage.workspace = true
[features]
default = ["git"]
@@ -23,13 +23,13 @@ name = "hx"
path = "src/main.rs"
[dependencies]
-helix-core = { version = "0.6", path = "../helix-core" }
-helix-event = { version = "0.6", path = "../helix-event" }
-helix-view = { version = "0.6", path = "../helix-view" }
-helix-lsp = { version = "0.6", path = "../helix-lsp" }
-helix-dap = { version = "0.6", path = "../helix-dap" }
-helix-vcs = { version = "0.6", path = "../helix-vcs" }
-helix-loader = { version = "0.6", path = "../helix-loader" }
+helix-core = { path = "../helix-core" }
+helix-event = { path = "../helix-event" }
+helix-view = { path = "../helix-view" }
+helix-lsp = { path = "../helix-lsp" }
+helix-dap = { path = "../helix-dap" }
+helix-vcs = { path = "../helix-vcs" }
+helix-loader = { path = "../helix-loader" }
anyhow = "1"
once_cell = "1.18"
@@ -79,7 +79,7 @@ libc = "0.2.150"
crossterm = { version = "0.27", features = ["event-stream", "use-dev-tty"] }
[build-dependencies]
-helix-loader = { version = "0.6", path = "../helix-loader" }
+helix-loader = { path = "../helix-loader" }
[dev-dependencies]
smallvec = "1.11"