aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2020-10-01 03:23:07 +0000
committerBlaž Hrastnik2020-10-01 03:25:03 +0000
commite39bd211d1579bfafa1774f6915af5725041781e (patch)
tree258a92098896a3e903da6b27a076388e2a6a0fb6 /helix-term/Cargo.toml
parent1da0be0aa045a4acd0246d82bf6214f8ec651476 (diff)
argh -> clap to speed up compilation (no syn/proc_macro)
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index ecbbe7d2..82eeb345 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -15,9 +15,10 @@ helix-core = { path = "../helix-core" }
helix-view = { path = "../helix-view", features = ["term"]}
anyhow = "1"
-argh = "0.1"
smol = "1"
num_cpus = "1.13"
-tui = { version = "0.11", default-features = false, features = ["crossterm"] }
-crossterm = { version = "0.17", features = ["event-stream"] }
+# tui = { version = "0.12", default-features = false, features = ["crossterm"] }
+tui = { git = "https://github.com/fdehau/tui-rs", default-features = false, features = ["crossterm"] }
+crossterm = { version = "0.18", features = ["event-stream"] }
+clap = { version = "3.0.0-beta.2 ", default-features = false, features = ["std"] }