aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-06-18 08:31:31 +0000
committerBlaž Hrastnik2021-06-20 07:38:58 +0000
commit9275021497fc13938317b681319ba571c8d5f478 (patch)
tree40e54a40a2d97eade3fcf3531bbf52559395970a /helix-term/Cargo.toml
parent59c59deb464d347be796735b2d15f5a19a38bf3f (diff)
ui: prompt: Better unicode support
We copied over eval_movement from wezterm, that already solves most of our problems. self.cursor is now byte-based.
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index 385af64c..24741796 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -54,3 +54,6 @@ toml = "0.5"
serde_json = "1.0"
serde = { version = "1.0", features = ["derive"] }
+
+unicode-segmentation = "1.7"
+unicode-width = "0.1"