summaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorSkyler Hawthorne2022-01-18 00:04:40 +0000
committerSkyler Hawthorne2022-06-19 03:54:03 +0000
commit502d3290fb88d8a871b0824adc7987a98104933d (patch)
tree5348192b2237e97f3bc0068503279760e8c187f5 /helix-term/Cargo.toml
parent308cab3e5cd5e8d5a8c37498e725f51ab101a908 (diff)
improve test harness
* Use new macro syntax for encoding sequences of keys * Make convenience helpers for common test pattern * Use indoc for inline indented raw strings * Add feature flag for integration testing to disable rendering
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index 0f80c416..05f8eed4 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -17,6 +17,7 @@ app = true
[features]
unicode-lines = ["helix-core/unicode-lines"]
+integration = []
[[bin]]
name = "hx"
@@ -73,3 +74,7 @@ signal-hook-tokio = { version = "0.3", features = ["futures-v0_3"] }
[build-dependencies]
helix-loader = { version = "0.6", path = "../helix-loader" }
+
+[dev-dependencies]
+smallvec = "1.8"
+indoc = "1.0.3"