summaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2020-10-23 05:33:09 +0000
committerBlaž Hrastnik2020-12-03 04:10:35 +0000
commitaf1924404adac399c351a17bc0f43b5e2889abbb (patch)
tree69b9a940b4d98f82233c1b61c52516a81bca7d59 /helix-term/Cargo.toml
parenteff6fac9ece0700f0ed8eb0a230b6816fa7cece7 (diff)
Configure logging (-vv for debug level logs)
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index db1edee9..c1560ee7 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -19,10 +19,15 @@ helix-lsp = { path = "../helix-lsp"}
anyhow = "1"
smol = "1"
-num_cpus = "1.13"
+num_cpus = "1"
# tui = { version = "0.12", default-features = false, features = ["crossterm"] }
tui = { git = "https://github.com/fdehau/tui-rs", default-features = false, features = ["crossterm"] }
crossterm = { version = "0.18", features = ["event-stream"] }
clap = { version = "3.0.0-beta.2 ", default-features = false, features = ["std", "cargo"] }
futures-util = "0.3"
+
+# Logging
+fern = "0.6"
+chrono = "0.4"
+log = "0.4"