aboutsummaryrefslogtreecommitdiff
path: root/helix-tui/Cargo.toml
diff options
context:
space:
mode:
authorMichael Davis2023-03-05 18:13:11 +0000
committerBlaž Hrastnik2023-03-08 01:49:32 +0000
commit611701c36290b81c3c51ed30c49245f341a580e8 (patch)
treeefe00b6d01253f1e32cf43556d55b30f798a4640 /helix-tui/Cargo.toml
parent3d850247177f61601296fe5b1cdada8819137783 (diff)
tui: Cache the keyboard enhancement check
Wether the host terminal supports keyboard enhancement can be cached for the lifetime of a Helix session. Caching this lookup prevents a potential lockup within crossterm's event reading system where the query for the keyboard enhancement support waits on the next keyboard event, which can happen if the crossterm event stream is checked by `tokio::select!` in another thread.
Diffstat (limited to 'helix-tui/Cargo.toml')
-rw-r--r--helix-tui/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/helix-tui/Cargo.toml b/helix-tui/Cargo.toml
index 3ca7e044..8a6d5367 100644
--- a/helix-tui/Cargo.toml
+++ b/helix-tui/Cargo.toml
@@ -22,6 +22,7 @@ unicode-segmentation = "1.10"
crossterm = { version = "0.26", optional = true }
termini = "0.1"
serde = { version = "1", "optional" = true, features = ["derive"]}
+once_cell = "1.17"
log = "~0.4"
helix-view = { version = "0.6", path = "../helix-view", features = ["term"] }
helix-core = { version = "0.6", path = "../helix-core" }