aboutsummaryrefslogtreecommitdiff
path: root/helix-vcs/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel2023-02-20 15:48:13 +0000
committerBlaž Hrastnik2023-03-05 06:54:02 +0000
commitac9e0b39f2d217f1c40a7e536e15009b21423610 (patch)
tree700ffab480ae69a2bf86eaf1440e149c40e08c84 /helix-vcs/Cargo.toml
parent725d9aecf08262e83553e54aa57d9bbec4841c80 (diff)
upgrade `git-repository` to `gix` 0.36.1; up min. rustc version to 1.64
This fixes breakage when installing `helix` due to an incorrect usage of `as_ref()` when interacting with `bstr` in the `gitoxide` codebase. However, this upgrade also requires a higher rustc version, as `gitoxide` recently updated its `windows` crate version.
Diffstat (limited to 'helix-vcs/Cargo.toml')
-rw-r--r--helix-vcs/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/helix-vcs/Cargo.toml b/helix-vcs/Cargo.toml
index c4d6eb45..ad8005d1 100644
--- a/helix-vcs/Cargo.toml
+++ b/helix-vcs/Cargo.toml
@@ -16,13 +16,13 @@ helix-core = { version = "0.6", path = "../helix-core" }
tokio = { version = "1", features = ["rt", "rt-multi-thread", "time", "sync", "parking_lot", "macros"] }
parking_lot = "0.12"
-git-repository = { version = "0.32", default-features = false , optional = true }
+gix= { version = "0.36.1", default-features = false , optional = true }
imara-diff = "0.1.5"
log = "0.4"
[features]
-git = ["git-repository"]
+git = ["gix"]
[dev-dependencies]
tempfile = "3.4" \ No newline at end of file