aboutsummaryrefslogtreecommitdiff
path: root/helix-view/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2020-09-21 09:24:16 +0000
committerBlaž Hrastnik2020-09-21 09:24:16 +0000
commit935cfeae576f734e6cbd455bfa39df014700ae86 (patch)
treea4abe959b718f265ade4a66a844bfefadc546f90 /helix-view/Cargo.toml
parent48330ddb5f36a1c5f44a636525089a019ce4439d (diff)
Split parts of helix-term into helix-view.
It still largely depends on term for some types but I plan to change that later.
Diffstat (limited to 'helix-view/Cargo.toml')
-rw-r--r--helix-view/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/helix-view/Cargo.toml b/helix-view/Cargo.toml
new file mode 100644
index 00000000..37957625
--- /dev/null
+++ b/helix-view/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "helix-view"
+version = "0.1.0"
+authors = ["Blaž Hrastnik <blaz@mxxn.io>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[features]
+term = ["tui", "crossterm"]
+
+[dependencies]
+anyhow = "1.0.32"
+helix-core = { path = "../helix-core" }
+
+# Conversion traits
+tui = { version = "0.10.0", default-features = false, features = ["crossterm"], optional = true}
+crossterm = { version = "0.17", features = ["event-stream"], optional = true}