aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-06-07 12:33:17 +0000
committerBlaž Hrastnik2021-06-07 12:33:17 +0000
commitd5de9183ef8392168b06131278554e483eddfff3 (patch)
tree8a0cfe6ed86e1f2cb624258d1f15aad3807ad276 /shell.nix
parent8d6fad4cac65083a0b08e49391c579ec793bc8f3 (diff)
Use upstream jsonrpc again
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 9e7bce9b..d6cb543a 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,4 +1,4 @@
-{ stdenv, pkgs }:
+{ lib, stdenv, pkgs }:
pkgs.mkShell {
nativeBuildInputs = with pkgs; [
@@ -12,7 +12,9 @@ pkgs.mkShell {
RUSTFLAGS = "-C link-arg=-fuse-ld=lld -C target-cpu=native";
RUST_BACKTRACE = "1";
# https://github.com/rust-lang/rust/issues/55979
- LD_LIBRARY_PATH="${stdenv.cc.cc.lib}/lib64:$LD_LIBRARY_PATH";
+ LD_LIBRARY_PATH = lib.makeLibraryPath (with pkgs; [
+ stdenv.cc.cc.lib
+ ]);
shellHook = ''
export HELIX_RUNTIME=$PWD/runtime