aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorScott Dunlop2021-06-01 22:03:57 +0000
committerGitHub2021-06-01 22:03:57 +0000
commit60caaf7fc46e5cbbd14fe116bae50d91bc954c18 (patch)
tree100cfe03d3aefad55f762a356062c4fe1e171e53 /shell.nix
parentc2e6b9f506fddec15e48bd06cf712aef2bf53e3c (diff)
Make HELIX_RUNTIME depend on pwd, not speed's HOME
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index b6274581..180e8957 100644
--- a/shell.nix
+++ b/shell.nix
@@ -12,7 +12,7 @@ pkgs.mkShell {
# https://github.com/rust-lang/rust/issues/55979
LD_LIBRARY_PATH="${stdenv.cc.cc.lib}/lib64:$LD_LIBRARY_PATH";
- # HELIX_RUNTIME=./runtime;
- HELIX_RUNTIME="/home/speed/src/helix/runtime";
+ shellHook = ''
+ export HELIX_RUNTIME=$PWD/runtime
+ '';
}
-