aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJappie Klooster2022-04-20 14:55:09 +0000
committerGitHub2022-04-20 14:55:09 +0000
commitb0bceb5674717c2c9f2d3b4c5526107d1c084e31 (patch)
treea9c1bba3712d2202081d467a6da86cec18413085 /shell.nix
parent961647719769e6b2baa8ae74630c16ab8963fa61 (diff)
Fix nix shell by hardcoding the flakecompat library (#2196)
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 5c5a774e..c0d998e3 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,9 @@
# Flake's devShell for non-flake-enabled nix instances
let
- src = (builtins.fromJSON (builtins.readFile ./flake.lock)).nodes.flakeCompat.locked;
- compat = fetchTarball { url = "https://github.com/edolstra/flake-compat/archive/${src.rev}.tar.gz"; sha256 = src.narHash; };
+ compat =
+ builtins.fetchGit {
+ url = "https://github.com/edolstra/flake-compat.git";
+ rev = "b4a34015c698c7793d592d66adbab377907a2be8";
+ };
in
(import compat { src = ./.; }).shellNix.default