aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 71825431..c4838ffd 100644
--- a/flake.nix
+++ b/flake.nix
@@ -35,6 +35,8 @@
overrides = {
crateOverrides = common: _: rec {
helix-term = prev: {
+ # disable fetching and building of tree-sitter grammars in the helix-term build.rs
+ HELIX_DISABLE_AUTO_GRAMMAR_BUILD = "1";
buildInputs = (prev.buildInputs or [ ]) ++ [ common.cCompiler.cc.lib ];
nativeBuildInputs = (prev.nativeBuildInputs or [ ]) ++ [ common.pkgs.makeWrapper ];
preConfigure = ''