diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 17 |
1 files changed, 1 insertions, 16 deletions
@@ -30,22 +30,7 @@ }; # link languages and theme toml files since helix-view expects them helix-view = _: { preConfigure = "ln -s ${common.root}/{languages.toml,theme.toml} .."; }; - helix-syntax = prev: { - src = - let - pkgs = common.pkgs; - helix = pkgs.fetchgit { - url = "https://github.com/helix-editor/helix.git"; - rev = "d4bd5b37669708361a0a6cd2917464b010e6b7f5"; - fetchSubmodules = true; - sha256 = "sha256-KayR7K7UC0mT6EjHsZsCYY9IVDJzft63fGpPKGSY8nQ="; - }; - in - pkgs.runCommand prev.src.name { } '' - mkdir -p $out - ln -s ${prev.src}/* $out - ln -sf ${helix}/helix-syntax/languages $out - ''; + helix-syntax = _prev: { preConfigure = "mkdir -p ../runtime/grammars"; postInstall = "cp -r ../runtime $out/runtime"; }; |