aboutsummaryrefslogtreecommitdiff
path: root/grammars.nix
diff options
context:
space:
mode:
Diffstat (limited to 'grammars.nix')
-rw-r--r--grammars.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/grammars.nix b/grammars.nix
index 2f50662e..066fa69d 100644
--- a/grammars.nix
+++ b/grammars.nix
@@ -4,6 +4,8 @@
runCommandLocal,
runCommandNoCC,
yj,
+ includeGrammarIf ? _: true,
+ ...
}: let
# HACK: nix < 2.6 has a bug in the toml parser, so we convert to JSON
# before parsing
@@ -102,12 +104,13 @@
runHook postFixup
'';
};
+ grammarsToBuild = builtins.filter includeGrammarIf gitGrammars;
builtGrammars =
builtins.map (grammar: {
inherit (grammar) name;
artifact = buildGrammar grammar;
})
- gitGrammars;
+ grammarsToBuild;
grammarLinks =
builtins.map (grammar: "ln -s ${grammar.artifact}/${grammar.name}.so $out/${grammar.name}.so")
builtGrammars;