aboutsummaryrefslogtreecommitdiff
path: root/helix-core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'helix-core/Cargo.toml')
-rw-r--r--helix-core/Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/helix-core/Cargo.toml b/helix-core/Cargo.toml
index 51096453..ea695d34 100644
--- a/helix-core/Cargo.toml
+++ b/helix-core/Cargo.toml
@@ -1,8 +1,8 @@
[package]
name = "helix-core"
-version = "0.4.1"
+version = "0.5.0"
authors = ["Blaž Hrastnik <blaz@mxxn.io>"]
-edition = "2018"
+edition = "2021"
license = "MPL-2.0"
description = "Helix editor core editing primitives"
categories = ["editor"]
@@ -13,7 +13,7 @@ include = ["src/**/*", "README.md"]
[features]
[dependencies]
-helix-syntax = { version = "0.4", path = "../helix-syntax" }
+helix-syntax = { version = "0.5", path = "../helix-syntax" }
ropey = "1.3"
smallvec = "1.7"
@@ -27,6 +27,7 @@ once_cell = "1.8"
arc-swap = "1"
regex = "1"
+log = "0.4"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
toml = "0.5"