aboutsummaryrefslogtreecommitdiff
path: root/helix-lsp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'helix-lsp/Cargo.toml')
-rw-r--r--helix-lsp/Cargo.toml21
1 files changed, 8 insertions, 13 deletions
diff --git a/helix-lsp/Cargo.toml b/helix-lsp/Cargo.toml
index f4d2849f..1384ce67 100644
--- a/helix-lsp/Cargo.toml
+++ b/helix-lsp/Cargo.toml
@@ -10,19 +10,14 @@ license = "MPL-2.0"
[dependencies]
helix-core = { path = "../helix-core" }
-once_cell = "1.4"
-
+anyhow = "1.0"
+futures-executor = "0.3"
+futures-util = { version = "0.3", features = ["std", "async-await"], default-features = false }
+jsonrpc-core = { version = "17.1", default-features = false } # don't pull in all of futures
+log = "0.4"
lsp-types = { version = "0.89", features = ["proposed"] }
-tokio = { version = "1", features = ["full"] }
-tokio-stream = "0.1.5"
-futures-executor = { version = "0.3" }
-url = "2"
-pathdiff = "0.2"
-glob = "0.3"
-anyhow = "1"
-serde_json = "1.0"
serde = { version = "1.0", features = ["derive"] }
-jsonrpc-core = { version = "17.1", default-features = false } # don't pull in all of futures
-futures-util = { version = "0.3", features = ["std", "async-await"], default-features = false }
+serde_json = "1.0"
thiserror = "1.0"
-log = "~0.4"
+tokio = { version = "1.6", features = ["full"] }
+tokio-stream = "0.1.6" \ No newline at end of file