aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml11
1 files changed, 5 insertions, 6 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index 3a8321aa..1cb2c3bc 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -17,12 +17,11 @@ path = "src/main.rs"
anyhow = "1.0.31"
argh = "0.1.3"
helix-core = { path = "../helix-core" }
-# crossterm = { version = "0.17.5", features = ["event-stream"] }
-crossterm = { git = "https://github.com/crossterm-rs/crossterm", branch = "mio-update", features = ["event-stream"] }
+crossterm = { version = "0.17.7", features = ["event-stream"] }
-futures = { version = "0.3.5", default-features = false, features = ["std"] }
+smol = "0.3"
+futures = { version = "0.3.5", default-features = false, features = ["std", "async-await"] }
# futures-timer = "3.0.2"
-smol = "0.1.10"
-num_cpus = "1.13.0"
-piper = "0.1.2"
+# async-channel = "1.4.0"
+
# tui = { version = "0.9.5", default-features = false }